View Single Post
Old 08-01-2013, 03:04 PM   #1
Tharic-Nar
Techgage Staff
 
Tharic-Nar's Avatar
 
Join Date: Nov 2009
Location: UK
Posts: 1,166
Default The PC that would never turn off and how I saved the world

Before I get into the nitty-gritty of the title, I'll just give you a little background. I currently work for a place that deals with hardware repair of electronics and electro-mechanical assemblies, with my place being seated in the PC and PCB area. Today, a computer graced my desk with a peculiar and, at first, an unknown problem. A spot inspection showed that it had blown a multitude of its capacitors (these are old systems, 2.4GHz Pentium 4s). Recapping a board is fairly straightforward, if a little tedious. After the initial repair, I booted it up fine, everything was working, and put it through the usual assortment of stress-testing. It past everything without a hitch... until it came time to shut it down.

Part of the testing process is to boot the unit from both network images and from a local test hard drive with good old Win XP loaded. I booted the system up into XP, ran some additional tests, then shut it down so I could boot it up on the network. As it was shutting down, I went to check up on another unit that was benching, turned back and the unit I thought I had shutdown was still in Windows. So I go to shut it down again, this time hanging around and waiting for it to complete. I see the screen goes blank, the fans stop spinning, I thought all was well... until 5 seconds later, when It was now hitting the POST screen again. I look on, puzzled.

While it's half way through POST, I hit the power button again to turn it off. The fans spin down, and the unit goes dead... for 5 seconds and begins booting again. This is when I start going from my 'Puzzled' face to 'WTF' face. I catch the POST startup and check the BIOS, see if there are any abnormalities in the power settings, such as wake on LAN, KB, last power-on state, etc. Nothing out of the ordinary at all. I disconnect both KB and LAN, so that the only thing connected to the PC was the monitor and power. It was still booting up.

It's at this point I got really concerned and went to a colleague for help. I explain the situation, he pulls a funny face, we walk over to the unit and we both look dumbstruck as this PC kept turning itself on, regardless of the hardware configuration. We even removed the front-panel switch (to see if it was shorting) and it was still booting! It's at this point, the glasses are dawned and the beard stroking begins.

The first and most obvious thing to check ( for us), is to see if we (I) had done something wrong while soldering all those new capacitors. Reversed polarity, solder splatter shorting something out, nicked another component, that kind of thing. It was through this careful analysis (about 30 seconds!) that my colleague noticed something missing from the board. There was no clock crystal on the board. I quickly scurried over, picked up another board laying around, compared the two, and sure enough, there was a crystal missing. This left me even more puzzled, since the caps I had to replace where nowhere near the crystal, and those things are secured in place with foam and all sorts. Checking the workbench showed that nothing had come off. The board came to us without a crystal!

This is when things get baffling. The system passed every test we threw at it, including a network matched timing test of the RTC (that uses these clock crystals), and there were no problems. The system remembered BIOS information and settings, kept time, communicated over serial, parallel, network and USB fine. Memory was fine, hard drive and optical was fine, graphics fine. Everything was fine, except this never shutdown issue. So, I marked out where the crystal was to go, hit the soldering iron, put everything back together, booted it up, shut it all down, and.... it stayed shut down!

So there you go people. A PC with a life of its own, ready to take over the world with malicious intent; powering itself back on just as you turn your back on the office to go home, after a long day's work. You can all rest easy now, knowing that I stopped its evil and vindictive plans, all because of a 1 cent watch crystal.

... though I would like know WHY that worked. Seriously.

Also, I saw my first PC today with RDRAM (that's Rambus if you don't know). While the stuff was used with consoles like the N64 and PS2, PC coverage was limited, and quickly ousted by the now ubiquitous DDR. And if you're wondering, yes, business still want PCs repaired, equipped with the latest and greatest bus standard, ISA.
__________________
PSU: Corsair 1000HX - Case: Thermaltake Xaser VI Full Tower - CPU: Intel Core i7 2600 @3.8GHz - Cooler: Thermaltake FRIO - Motherboard: ASUS P67 Sabertooth - Memory: 16GB Corsair Vengeance LP Arctic 1600 - GPU: 2x AMD Radeon HD 5870 - HDD: WD Caviar Black 1TB 6Gb/s +1TB +2TB storage - Audio: ODAC + O2 Amp, ASUS Xonar DX
K/B: Corsair K90 - Mouse: ROCCAT KONE XTD - Monitor: DELL U2410 - Speakers: Corsair SP2500 - Headphones: Beyerdynamic DT990 - Mic: Blue Yeti USB Microphone

- I need Fiber to fix my Irregular Bandwidth Syndrome -
Tharic-Nar is online now   Reply With Quote