Latest Forum Posts

Latest News Posts
Coming Soon!
Social
Go Back   Techgage.com > Archives > Reviews and Articles

Reviews and Articles Discussion for Techgage content is located here. Only staff can create topics, but everyone is welcome to post.

Reply
 
Thread Tools
Old 11-14-2006, 05:00 PM   #31
madmat
Soup Nazi
 
madmat's Avatar
 
Join Date: Jun 2005
Location: No soup for you!
Posts: 1,666
Default

Too many things on an unpowered hub might cause that but not just on ports. You might have a bad receiver which would explain why it likes being closer to the mouse. Try RMA'ing the unit (I think Logitech can hook you up so that you won't have to ship it back) and see if the replacement is better.
__________________

M4N82 Deluxe
Phenom II 940 Black Edition quad core @ 3.5Ghz
2x1 gig OCZ PC26400 Platinum, 2x1gig GSkill PC26400
EVGA GTX260
Upcoming EVGA GTX470
Buncha drives,
Some other stuff,
Even more stuff,
If the automobile had followed the same development cycle as the computer, a Rolls-Royce would today cost $100, get a million miles per gallon, and explode once a year, killing everyone inside. --Robert X. Cringely, InfoWorld magazine
madmat is offline   Reply With Quote
Old 11-15-2006, 02:38 AM   #32
zachig
Obliviot
 
Join Date: Mar 2006
Posts: 43
Default

Thanks...I guess I'll contact Logitech Help-Desk and see how can they help me...

Hopefully, they can send me another Reciever unit, so I can check it out.

Anyway, thanks for your advice and help.

If any of you will have some more info that might help, I'll be glad to hear...

THX.
zachig is offline   Reply With Quote
Old 11-16-2006, 01:14 PM   #33
Alpine
Guest Poster
 
Posts: n/a
Unhappy

I got one of a MX 610 this morning after reading your review, I was going to get a G5 but they were out of stock This mouse is perfect except the IM & email buttons. They link me to MSN & outlook but they don't light up. I've tried installing the newer version of set point like people say you should do but nothing changed.

Please help me!
  Reply With Quote
Old 11-16-2006, 03:11 PM   #34
zachig
Obliviot
 
Join Date: Mar 2006
Posts: 43
Default

Quote:
Originally Posted by Alpine View Post
I got one of a MX 610 this morning after reading your review, I was going to get a G5 but they were out of stock This mouse is perfect except the IM & email buttons. They link me to MSN & outlook but they don't light up. I've tried installing the newer version of set point like people say you should do but nothing changed.

Please help me!
Regarding MY problem, it seems that after I used an extension cable and moved the reciever VERY close to my mouse, the problem DOES NOT happen anymore!!! So I think it was a reception problem.

I also contacted Logitech Customer Support and they told me that sometimes, some of the cables at the back of my PC Case and/or some other metal things near my case (even the metal frame of the table... ) can interfere with the mouse receiver). That's why they advised me to use an extension cable for the USB and that's what I did.

Regarding YOUR problem, I also heard about these problems with IM and E-mail buttons, but sorry I can't help you out...

As far as I understood, these are driver-related issues, so maybe you should try contacting Logitech Support as well and get an advise.

I know that the IM is working for me, though I don't use the E-mail button, as it works ONLY with Outlook and I'm ONLY using my Gmail account.
zachig is offline   Reply With Quote
Old 11-16-2006, 03:35 PM   #35
Alpine
Guest Poster
 
Posts: n/a
Default

Quote:
Originally Posted by zachig View Post
Regarding MY problem, it seems that after I used an extension cable and moved the reciever VERY close to my mouse, the problem DOES NOT happen anymore!!! So I think it was a reception problem.

I also contacted Logitech Customer Support and they told me that sometimes, some of the cables at the back of my PC Case and/or some other metal things near my case (even the metal frame of the table... ) can interfere with the mouse receiver). That's why they advised me to use an extension cable for the USB and that's what I did.

Regarding YOUR problem, I also heard about these problems with IM and E-mail buttons, but sorry I can't help you out...

As far as I understood, these are driver-related issues, so maybe you should try contacting Logitech Support as well and get an advise.

I know that the IM is working for me, though I don't use the E-mail button, as it works ONLY with Outlook and I'm ONLY using my Gmail account.
That's not very useful if your using a notebook on the move & you just want to plug it in without wires. But as I'm on a normal PC I will do that! Thanks
  Reply With Quote
Old 11-16-2006, 03:53 PM   #36
Alpine
Guest Poster
 
Posts: n/a
Default

I've just been following the drive problems & none work damnit.

Sorry for double post. Guest cant edit.
  Reply With Quote
Old 11-16-2006, 07:50 PM   #37
madmat
Soup Nazi
 
madmat's Avatar
 
Join Date: Jun 2005
Location: No soup for you!
Posts: 1,666
Default

That's so weird! I've got my mouse 15-20 feet away from the receiver and it never skips a beat. Sorry to hear y'all are having troubles. You can use gmail with outlook/outlook express just so you know.

I wonder if your mouse is having problems with the buttons or something. Mine worked great although I'm using it sans drivers now.
__________________

M4N82 Deluxe
Phenom II 940 Black Edition quad core @ 3.5Ghz
2x1 gig OCZ PC26400 Platinum, 2x1gig GSkill PC26400
EVGA GTX260
Upcoming EVGA GTX470
Buncha drives,
Some other stuff,
Even more stuff,
If the automobile had followed the same development cycle as the computer, a Rolls-Royce would today cost $100, get a million miles per gallon, and explode once a year, killing everyone inside. --Robert X. Cringely, InfoWorld magazine
madmat is offline   Reply With Quote
Old 11-17-2006, 08:12 AM   #38
Alpine
Guest Poster
 
Posts: n/a
Default

Well it wasn't exactly what wanted so I've taken it back to the computer shop & I've ordered a G5. Should come tomorrow
  Reply With Quote
Old 11-20-2006, 12:55 AM   #39
Matt A
Guest Poster
 
Posts: n/a
Default

I have this mouse and it's great. The reviewer mentioned that the left tilt on the wheel was sticking and that he had trouble waking the mouse up, but I have experienced neither of those problems. Just make sure you have the latest software so that the forward and back keys work in Firefox.
  Reply With Quote
Old 11-20-2006, 01:58 AM   #40
zachig
Obliviot
 
Join Date: Mar 2006
Posts: 43
Default

Now, after I moved the Reciever to the front of my case, the reception is MUCH better, and I'm not facing the problems I've described anymore!!!

So now I can say, I'm pretty satisifed with this mouse.

Thanks for your help guys!!!
zachig is offline   Reply With Quote
Old 11-20-2006, 08:52 AM   #41
madmat
Soup Nazi
 
madmat's Avatar
 
Join Date: Jun 2005
Location: No soup for you!
Posts: 1,666
Default

Quote:
Originally Posted by Matt A View Post
I have this mouse and it's great. The reviewer mentioned that the left tilt on the wheel was sticking and that he had trouble waking the mouse up, but I have experienced neither of those problems. Just make sure you have the latest software so that the forward and back keys work in Firefox.
I don't have trouble waking up the rodent, I have trouble with it falling asleep too fast. When mine falls asleep the scroll wheel ceases to function until I shake the mouse or click a button. I can appreciate that they're saving me juice (trust me, I love it) but if the mouse went to sleep after 5 minutes of inactivity rather than 2 (or so) I'd really like it better.
__________________

M4N82 Deluxe
Phenom II 940 Black Edition quad core @ 3.5Ghz
2x1 gig OCZ PC26400 Platinum, 2x1gig GSkill PC26400
EVGA GTX260
Upcoming EVGA GTX470
Buncha drives,
Some other stuff,
Even more stuff,
If the automobile had followed the same development cycle as the computer, a Rolls-Royce would today cost $100, get a million miles per gallon, and explode once a year, killing everyone inside. --Robert X. Cringely, InfoWorld magazine
madmat is offline   Reply With Quote
Old 02-11-2007, 07:48 PM   #42
Unregistered
Guest Poster
 
Posts: n/a
Default

Personally I hate Logitech's drivers (Kensington has the best drivers but their mice are not so good), However, this: http://www.mstarmetro.net/~rlowens/uberOptions/ fixes a lot of Logitech's problems. (AWESOME software)
  Reply With Quote
Old 02-11-2007, 07:50 PM   #43
Unregistered
Guest Poster
 
Posts: n/a
Thumbs up

P.S. Thanks for the review
  Reply With Quote
Reply

Tags
None

Thread Tools

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Logitech G9 Laser Gaming Mouse Rob Williams Reviews and Articles 27 05-05-2009 12:44 AM
Logitech G3 Laser Mouse Rob Williams Reviews and Articles 27 06-20-2007 05:49 AM
Logitech G5 Laser Mouse Rob Williams Reviews and Articles 8 03-16-2007 02:43 PM
Logitech MX Revolution Laser Mouse Rob Williams Reviews and Articles 40 12-16-2006 01:45 PM
Discuss: Logitech MX1000 Laser Mouse Rob Williams Reviews and Articles 3 04-12-2005 04:42 PM


All times are GMT -4. The time now is 08:00 PM.